среда, 8 октября 2014 г.

Brocade: Failed to validate certificate. The application will not be executed.

java 7 update 45 (40)


Failed to validate certificate. The application will not be executed.

sun.security.validator.ValidatorException: PKIX path validation failed: java.security.cert.CertPathValidatorException: algorithm constraints check failed


Официальная позиция: "update 45 is not supported. Remove it and Install Java 7 update 21 or preview release"

где собака порылась:  в  $JAVA_HOME/jre/lib/security/java.security
- jdk.certpath.disabledAlgorithms=MD2, RSA keySize < 1024
+jdk.certpath.disabledAlgorithms=MD2, RSA keySize < 256



троллинг от гугол